Arx Libertatis Bug Tracker
Please log in to bookmark issues
CLOSED  Bug report #1317  -  Unexpected newline on a few commands
Posted Jan 23, 2019 - updated Mar 02, 2019   Shortlink:
icon_info.png This issue has been closed with status "Not a bug" and resolution "NOT AN ISSUE".
Issue details
  • Type of issue
    Bug report
  • Status
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
  • Priority
    Not determined
  • Reproducability
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Using the console to type out a few commands will give "unexpected newline" error and not activate it.
Steps to reproduce this issue
Writing "move" plus coordinates will cause the error "unexpected newline". I've tried the following commands, "invulnerability", "move" "teleport" and they all give the same error. There might be a few more console commands causing this same problem. In an attempt to get unstuck from location in the map(new bug report will come up soon over this -- later during the day).

Using the latest dev release snapshot, Arx Libertatis 1.2-dev-2019-01-13.

Comment posted by
 Daniel Scharrer
Jan 25, 03:48
Please attach your arx.log file so we can see the exact commands and error messages.

The move command takes three arguments - the x, y and z coordinates of the movement vector to add to the position. It also probably won't work for the player character which has different handling for the position.

The invulnerability command takes an boolean argument ("on" or "off") that indicates if invulnerability should be enabled or disabled.

The teleport command has a couple of forms. For the player you need the -p flag and the ID of an entity (ie a marker) to teleport to.

The easiest way to get unstuck is to use the passwall cheat.
Comment posted by
Jan 25, 12:44
A file was uploaded. arx.logicon_open_new.png
Comment posted by
Jan 25, 12:45
Uploaded the log file, I tested a few other commands as well.
Comment posted by
 Daniel Scharrer
Mar 02, 07:22
"unexpected newline" here just means that you didn't pass the command enough arguments

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to NOT AN ISSUE.