Arx Libertatis Bug Tracker
Arx Libertatis (arx)
January 17, 2018
bug_report_tiny.png 02:17  Bug report #1134 - Rune drawing not working
dscharrer : Issue closed
January 16, 2018
bug_report_tiny.png 09:52  Bug report #1135 - Camera angle issues, looks near but not on characters during cutscenes
guest : Issue created
It seems to be somewhat random but common for the camera during cutscenes that have more than one shot, (e.g. that cut from character to character) to have increasingly poor camera placement with every new cut.

I am currently running the game in 1440x900. It does however seem to still happen, albeit to a lesser extent, when I'm in 640x480. Here is video of the bug in 640x480. Here is the save itself.
January 15, 2018
bug_report_tiny.png 20:33  Bug report #1134 - Rune drawing not working
guest : Issue created
After I pick up the first two runes in the game, the straight horizontal line one doesn't work. It makes a noise, but always shows up as a cross in the top right corner. The 'U' one seems to work fine.

I've tried changing VSync on and off, dabbled with framerates, used improved run recognition, but to no avail.

I'm running on the latest dev snapshot of the game (1/14/18, I believe)
bug_report_tiny.png 17:25  Bug report #1132 - Trap spell does not end when triggered
dscharrer : Issue closed
bug_report_tiny.png 17:24  Bug report #1130 - When double clicking an item, items flash even though they can't be combined. PART 2
dscharrer : Issue closed
January 14, 2018
feature_request_tiny.png 23:23  Feature request #1133 - Color of the player's blood particles can not be changed
guest : Issue created
When you change the color of the player's blood in the script file, it has no effect in-game, showing the bright red color of vanilla.

The change of color of the blood of the npcs works well (The change of color is fundamental for me, since I want a darker and realistic tone)

Moddified blood doesn't work (INIT):

SET_BLOOD 0.08 0.00 0.00
SETIRCOLOR 0.5 0.0 0.0

-Pedro Ordaz, it would be great to have this feature, thanks
bug_report_tiny.png 21:09  Bug report #1132 - Trap spell does not end when triggered
guest : Issue created
First - great job guys!

So i found 2 "problems" with traps.
1: If you precast trap to 1-2-3 hotkeys, then change zone, the trap refuses to cast from those keys (you can hear the sound of the casting it, see the red light, the hotkey-ed spell disappears as if it's properly casted, but no trap on the ground).
2: When someone triggers it it doesn't consume the trap, so it keeps dealing damage until the target is dead. Managed to kill final boss within 2-3 seconds with 3 pre-casted traps.

Everything else seemed to work fine. Great job with the Libertatis port, worked flawlesly on win10! (bow)
bug_report_tiny.png 20:53  Bug report #1131 - Strange black space
dscharrer : Issue closed
bug_report_tiny.png 20:35  Bug report #1131 - Strange black space
Telendil : Issue created
When moving on level 6 in a certain place (save below), some of the image disappears. Works only when the camera is in a certain position.
In the saves below, the position of the view is precisely directed to the source of the problem - not to move or move the mouse.
bug_report_tiny.png 19:32  Bug report #1130 - When double clicking an item, items flash even though they can't be combined. PART 2
Telendil : Issue created
At the moment, the object is seen with the Assassin dagger. It flashes with any objects.
update: looks like all weapon flashes, not only Assassin dagger.
bug_report_tiny.png 19:20  Bug report #1129 - Light source of the protective field
Telendil : Issue created
The source of illumination of the protective field doesn't disappear, after its deactivation at a level 4.
bug_report_tiny.png 18:58  Bug report #1128 - Duplicated sound when opening secondary inventories
Telendil : Issue created
When a player searches a corpse(don't know, it works with chests and barrels or not) with a closed inventory, there is a double sound of opening inventory. The same thing happens with the closure, if you inventory and the object being searched inventory are open at the same time.
January 13, 2018
bug_report_tiny.png 21:58  Bug report #790 - Durability decreases too fast
dscharrer : Issue closed
bug_report_tiny.png 21:11  Bug report #1014 - No Subtitles/Black Bars During a Pivotal Cutscene
dscharrer : Issue closed
bug_report_tiny.png 21:07  Bug report #1026 - Resizing window while top-level options menu results in empty sub-window
dscharrer : Issue closed
bug_report_tiny.png 21:06  Bug report #1127 - Top-level options and save/load menues are closed when resizing the window
dscharrer : Issue created
The individual Video / Interface / Audio / Control setting windows or the individual Load / Save windows handle window size changes without problems.
January 10, 2018
bug_report_tiny.png 16:24  Crash report #1126 - [E572619B] arx.exe!CrashHandlerWindows::handleCrash() crashhandlerwindows.cpp(312)
dscharrer : Issue closed
bug_report_tiny.png 05:05  Crash report #1126 - [E572619B] arx.exe!CrashHandlerWindows::handleCrash() crashhandlerwindows.cpp(312)
CrashBot : Issue created
new operator failed

arx.exe!CrashHandlerWindows::handleCrash() crashhandlerwindows.cpp(312)
arx.exe!NewHandler() crashhandlerwindows.cpp(433)
MSVCR100.dll!void * __ptr64 __cdecl operator new(unsigned __int64)()
arx.exe!std::allocator<SaveBlock::File::Chunk>::allocate() xmemory(187)
arx.exe!std::vector<SaveBlock::File::Chunk,std::allocator<SaveBlock::File::Chunk> >::reserve() vector(751)
arx.exe!std::vector<SaveBlock::File::Chunk,std::allocator<SaveBlock::File::Chunk> >::resize() vector(864)
arx.exe!SaveBlock::File::loadOffsets() saveblock.cpp(109)
arx.exe!SaveBlock::loadFileTable() saveblock.cpp(321)
arx.exe!SaveBlock::open() saveblock.cpp(382)
arx.exe!ARX_CHANGELEVEL_Save() changelevel.cpp(2802)
arx.exe!SaveGameList::save() savegame.cpp(233)
arx.exe!ARXMenu_SaveQuest() menupublic.cpp(323)
arx.exe!CMenuElementText::OnMouseClick() menuwidgets.cpp(2053)
arx.exe!CWindowMenuConsole::Update() menuwidgets.cpp(3519)
arx.exe!CWindowMenu::Render() menuwidgets.cpp(3039)
arx.exe!Menu2_Render() menuwidgets.cpp(1592)
arx.exe!ARX_Menu_Render() menu.cpp(398)
arx.exe!ArxGame::Render() arxgame.cpp(959)
arx.exe!ArxGame::Run() arxgame.cpp(599)
arx.exe!WinMain() startup.cpp(174)
arx.exe!__tmainCRTStartup() crtexe.c(547)

RAX:0000000000276250 RBX:0000000000000000 RCX:0000000000276250 RDX:0000000000000000 RSI:0000000000000000 RDI:0000000000000000
SS:RSP:002B:000000000012FF90 RBP:0000000000000000
DS:002B ES:002B FS:0053 GS:002B
bug_report_tiny.png 04:37  Bug report #1124 - Precast spells are not saved correctly
dscharrer : Issue closed
bug_report_tiny.png 04:36  Bug report #1112 - The heart is not displayed in the golem
dscharrer : Issue closed
bug_report_tiny.png 04:35  Bug report #1125 - Bookmarks in the diary make a double sound
dscharrer : Issue closed
bug_report_tiny.png 04:35  Bug report #121 - When double clicking an item, items flash even though they can't be combined.
dscharrer : Issue closed
January 09, 2018
bug_report_tiny.png 22:17  Bug report #1125 - Bookmarks in the diary make a double sound
Telendil : Issue created
When you switch tabs in a diary, a page turning sound is produced. If you switch tabs by pressing F1, F2, F3 - all okay. But if you switch the tabs with the mouse, it sounds double.

Version 1.2-dev-2018-01-09.
bug_report_tiny.png 21:39  Bug report #1124 - Precast spells are not saved correctly
Telendil : Issue created
If the player remembers the spell (by the "Shift") on the area(Ice field, Fire field...) or spells on the characters around(Mass paralyze..) and moves to the new zone, the stored spells do not work. They make a sound, but nothing happens.
bug_report_tiny.png 21:04  Bug report #1123 - Magic field in the castle of Arx
Telendil : Issue created
There is a teleport in Arx Castle. In front of him is a magical protective field, which can be deactivated by touching, or by pressing a button. Before any interaction with the protective field, it makes a sound. After the interaction, the sound dries and does not appear any more.
bug_report_tiny.png 17:48  Bug report #1118 - Can't cast ENCHANT OBJECT on "Ready to Be Enchanted" Meteor Sword, but can use ENCHANT OBJECT scroll.
dscharrer : Issue closed
bug_report_tiny.png 11:24  Bug report #1120 - The key to the Sacred Dagger and a key ring
dscharrer : Issue closed
bug_report_tiny.png 10:51  Crash report #1122 - [F4FF2BE5] arx.exe!ARX_SCRIPT_Timer_Check() [script.cpp:1841]
dscharrer : Issue closed
January 08, 2018
bug_report_tiny.png 19:03  Crash report #1122 - [F4FF2BE5] arx.exe!ARX_SCRIPT_Timer_Check() [script.cpp:1841]
CrashBot : Issue created
Assertion Failed at Script.cpp:1841: st->start <= now

Unhandled exception

Exception code: BREAKPOINT

Instruction address: 0x1401f7565
Stack pointer: 0x13f670

0 arx.exe!ARX_SCRIPT_Timer_Check() [script.cpp : 1841 + 0x1e]
1 arx.exe!ArxGame::updateLevel() [arxgame.cpp : 1871 + 0x0]
2 arx.exe!ArxGame::render() [arxgame.cpp : 2230 + 0x0]
3 arx.exe!ArxGame::doFrame() [arxgame.cpp : 1336 + 0x0]
4 arx.exe!ArxGame::run() [arxgame.cpp : 1261 + 0x0]
5 arx.exe!runGame() [core.cpp : 292 + 0x0]
6 arx.exe!utf8_main(int,char * * const) [startup.cpp : 207 + 0x0]
7 arx.exe!WinMain [windowsmaingui.cpp : 48 + 0xe]
8 arx.exe!__tmainCRTStartup [crtexe.c : 618 + 0x15]
January 06, 2018
enhancement_tiny.png 10:06  Enhancement #1121 - Ambient Music - Sacred Dagger
Telendil : Issue created
When you first come to the rebel camp, during a conversation with Alia plays a special ambient ([]), but after the heat it changes to the one who plays in the city of Arks ([]). And the new ambient is no longer playing.
Arx Fatalis can not boast a lot of ambient, so it's worth changing to Ambient Music - Sacred Dagger.
bug_report_tiny.png 09:48  Bug report #1120 - The key to the Sacred Dagger and a key ring
Telendil : Issue created
The key to the Sacred Dagger can not be combined with a key ring, but when you try to do this, the key ring blinking, as if you could do it.
This problem exists in the original Arx Fatalis too.
January 05, 2018
bug_report_tiny.png 01:10  Bug report #1119 - Some character scripts do not set unique names
Telendil : Issue created
During the game the player meets unique characters.Before talking with them, they are called basically - man, woman, troll, goblin. Running dialogue with them, the player gets the name of the character. But in some cases, the names do not replace - Man, Woman, Troll, Goblin. '''Perhaps this is due to the incompatibility of the new AL with the Russian version.''' This problem was in the original Arx too. But in the new version of Al, almost all the characters remain - Man, Woman, Troll, Goblin.
January 02, 2018
bug_report_tiny.png 02:55  Bug report #1118 - Can't cast ENCHANT OBJECT on "Ready to Be Enchanted" Meteor Sword, but can use ENCHANT OBJECT scroll.
guest : Issue created
When enchanting the Ultimate Weapon, I can use a Enchant Object scroll to do so but I can't use a spell. When I try to cast the spell and then click on the weapon on the ground, my character says that he can't do that.
January 01, 2018
bug_report_tiny.png 11:31  Crash report #1117 - [96674D9C] arx.exe!MiniMap::getData() [MiniMap.cpp : 102]
CrashBot : Issue created
Illegal storage access

Exception code: ACCESS_VIOLATION

Instruction address: 0x140175278
Memory accessed: 0x4
Stack pointer: 0x12f7c0

0 arx.exe!MiniMap::getData(int showLevel) Line 102 C++
1 arx.exe!MiniMap::showPlayerMiniMap(int showLevel) Line 288 C++
2 arx.exe!ArxGame::renderLevel() Line 2056 C++
3 arx.exe!ArxGame::render() Line 2154 C++
4 arx.exe!ArxGame::doFrame() Line 1303 C++
5 arx.exe!ArxGame::run() Line 1198 C++
6 arx.exe!runGame() Line 278 C++
7 arx.exe!utf8_main(int argc, char * * argv) Line 164 C++
8 arx.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow) Line 48 C++

December 31, 2017
bug_report_tiny.png 18:12  Crash report #1116 - [3E911621] arx.exe!SDLInputBackend::onInputEvent() [sdlinputbackend.cpp : 456]
bsxf47 : Issue closed
bug_report_tiny.png 17:56  Crash report #1116 - [3E911621] arx.exe!SDLInputBackend::onInputEvent() [sdlinputbackend.cpp : 456]
CrashBot : Issue created
Illegal storage access


0 arx.exe!SDLInputBackend::onInputEvent(const SDL_Event & event) Line 456 C++
1 arx.exe!SDLWindow::tick() Line 345 C++
2 arx.exe!ArxGame::Run() Line 559 C++
3 arx.exe!runGame() Line 842 C++
4 arx.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow) Line 875 C++
5 arx.exe!__tmainCRTStartup() Line 547 C

RAX:000000004016B711 RBX:0000000000000000 RCX:0000000000000000 RDX:0000000000D8F920 RSI:0000000000000000 RDI:0000000000000000
SS:RSP:002B:0000000000D8FF90 RBP:0000000000000000
DS:002B ES:002B FS:0053 GS:002B
bug_report_tiny.png 09:11  Crash report #1115 - [743A0852] ??!0x3f9fde9
CrashBot : Issue created
Illegal storage access

arx.exe!GLTexture2D::Upload() gltexture2d.cpp(95)
arx.exe!Texture2D::Restore() texture.cpp(76)
arx.exe!TextureContainer::LoadFile() texturecontainer.cpp(227)
arx.exe!TextureContainer::Load() texturecontainer.cpp(270)
arx.exe!ARX_Menu_Resources_Create() menu.cpp(155)
arx.exe!ARX_MENU_Launch() menu.cpp(305)
arx.exe!script::`anonymous namespace'::EndIntroCommand::execute() scriptedinterface.cpp(286)
arx.exe!ScriptEvent::send() scriptevent.cpp(426)
arx.exe!ARX_SCRIPT_Timer_Check() script.cpp(1956)
arx.exe!ArxGame::Render() arxgame.cpp(1312)
arx.exe!ArxGame::Run() arxgame.cpp(599)
arx.exe!WinMain() startup.cpp(174)
arx.exe!__tmainCRTStartup() crtexe.c(547)

EAX:03F9FDC0 EBX:7EFDE000 ECX:00000003 EDX:00000000 ESI:00000000 EDI:00000000
DS:002B ES:002B FS:0053 GS:002B
December 30, 2017
bug_report_tiny.png 17:36  Crash report #1114 - [A705A065] arx.exe!GetItemWorldPosition() [inventory.cpp : 1753]
bsxf47 : Issue closed
bug_report_tiny.png 16:56  Crash report #1114 - [A705A065] arx.exe!GetItemWorldPosition() [inventory.cpp : 1753]
CrashBot : Issue created
Illegal storage access


0 arx.exe!GetItemWorldPosition(Entity * io, Vector3<float> * pos) Line 1753 C++
1 arx.exe!ArxGame::ManageEditorControls() Line 2004 C++
2 arx.exe!ArxGame::Render() Line 1004 C++
3 arx.exe!ArxGame::Run() Line 599 C++
4 arx.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow) Line 174 C++
5 arx.exe!__tmainCRTStartup() Line 547 C

EAX:0C0544F0 EBX:00000000 ECX:00000000 EDX:0019FB78 ESI:00000000 EDI:0C0544F0
SS:ESP:002B:0019FFE4 EBP:0019FFEC
DS:002B ES:002B FS:0053 GS:002B
December 29, 2017
bug_report_tiny.png 22:47  Bug report #1113 - The blind cultist passes through the objects
Telendil : Issue created

A blind cultist walks through objects during prayer. This happens in the temple of Akbaa.
Show moreaction_add_small.png