Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1356  -  [3702BEF] arx.exe!angleToFrontUpVec() [math.cpp:477]
Posted Jun 04, 2019 - updated Jun 20, 2019   Shortlink: http://arx.vg/1356
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1307 - "[A411501D] arx.exe!angleToFrontUpVec() [math.cpp:477]"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Math.cpp:481: glm::abs(glm::dot(front, up)) < 5.f * std::numeric_limits<float>::epsilon() Message: front=(0.999238,-0.039013,0.001209) and up=(0.039013,0.999239,0.000047) should be orthogonal; dot=5.290841*epsilon

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x7ff651fa5d07
 Stack pointer: 0x42945bedf0


Callstack:
 arx.exe!0x7ff651fa5d07
 arx.exe!0x7ff651f47f61
 arx.exe!0x7ff651f49876
 arx.exe!0x7ff651f46109
 arx.exe!0x7ff651f578d9
 arx.exe!0x7ff6520528ba
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!angleToFrontUpVec(Angle<float> const &) [math.cpp : 477 + 0x9a]
 1  arx.exe!ArxGame::updateLevel() [arxgame.cpp : 1781 + 0x0]
 2  arx.exe!ArxGame::render() [arxgame.cpp : 2051 + 0x0]
 3  arx.exe!ArxGame::doFrame() [arxgame.cpp : 1288 + 0x0]
 4  arx.exe!utf8_main(int,char * * const) [startup.cpp : 164 + 0xab]
 5  arx.exe!WinMain [windowsmaingui.cpp : 48 + 0xe]
Steps to reproduce this issue
I downloaded the windows.zip from here: http://arx-libertatis.org/files/snapshots/arx-libertatis-1.2-dev-2019-01-04/

and copied the files to my game directory

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 04, 15:40
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-5548-3016131466
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 04, 15:40
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-5548-3016131466
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 04, 15:40
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-5548-3016131466
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 04, 15:40
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-5548-3016131466
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jun 20, 11:17
Please try the latest development snapshot, this has been fixed for a while.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.