Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1387  -  [AE0B54A] MSVCR100.dll!memcpy()
Posted Aug 26, 2019 - updated Sep 26, 2019   Shortlink: http://arx.vg/1387
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #466 - "[CB7612BA] MSVCR100.dll!memcpy() "
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png x86
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Callstack:
  MSVCR100.dll!memcpy() 
  arx.exe!D3DIndexBuffer<unsigned short>::setData()  d3d9vertexbuffer.h(67) 
  arx.exe!D3D9VertexBuffer<SMY_VERTEX>::drawIndexed()  d3d9vertexbuffer.h(170) 
  arx.exe!ARX_PORTALS_Frustrum_RenderRoomTCullSoft()  scene.cpp(2249) 
  arx.exe!ARX_PORTALS_Frustrum_RenderRoomsTCullSoft()  scene.cpp(1534) 
  arx.exe!ARX_SCENE_Render()  scene.cpp(2962) 
  arx.exe!ArxGame::Render()  arxgame.cpp(1696) 
  arx.exe!ArxGame::Run()  arxgame.cpp(599) 
  arx.exe!WinMain()  startup.cpp(174) 
  arx.exe!__tmainCRTStartup()  crtexe.c(547) 
  kernel32.dll!BaseThreadInitThunk() 
  ntdll.dll!RtlInitializeExceptionChain() 
  ntdll.dll!RtlInitializeExceptionChain() 


Registers:
  EAX:0E41C676  EBX:7EFDE000  ECX:00000015  EDX:00000000  ESI:00000000  EDI:00000000
  CS:EIP:0023:774497D5
  SS:ESP:002B:0018FFDC  EBP:0018FFEC
  DS:002B  ES:002B  FS:0053  GS:002B
  Flags:00210212


Steps to reproduce this issue
Nothing entered.

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Aug 26, 10:44
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-5320-284496005
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Aug 26, 10:44
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-5320-284496005
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Aug 26, 10:44
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-5320-284496005
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Aug 26, 10:44
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-5320-284496005
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Sep 26, 21:19
The D3D renderer is no longer supported. Please switch to the OpenGL renderer and report any issues you have with that.

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.