Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1476  -  [F75D4556] arx.exe!Trail::Render() [Trail.cpp:117]
Posted Jun 30, 2020 - updated Today (07:32)   Shortlink: http://arx.vg/1476
action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1468 - "Shooting with the bow implementation crashes the game"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png x86
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Trail.cpp:117: m_positions.size() >= size_t(std::ceil(n)) 2

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0xadc5f4
 Stack pointer: 0x137f3f0
 Frame pointer: 0x137f5e8


Callstack:
 Warning: WoW64 process detected, stack may be corrupted!
 arx.exe!0xadc5f4
 arx.exe!0xaac7cf
 arx.exe!0xa9f723
 arx.exe!0xa745b7
 arx.exe!0xa74f4e
 arx.exe!0xa718ba
 arx.exe!0xa70d4e
 arx.exe!0xa80d9f
 arx.exe!FT_Library_SetLcdFilterWeights()
Symbols:
 0  arx.exe!Trail::Render() [Trail.cpp : 117 + 0x16]
 1  arx.exe!SpeedSpell::Update() [SpellsLvl03.cpp : 129 + 0x0]
 2  arx.exe!ARX_SPELLS_Update() [Spells.cpp : 1093 + 0x0]
 3  arx.exe!ArxGame::renderLevel() [ArxGame.cpp : 1950 + 0x0]
 4  arx.exe!ArxGame::render() [ArxGame.cpp : 2082 + 0x0]
 5  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1304 + 0x0]
 6  arx.exe!ArxGame::run() [ArxGame.cpp : 1168 + 0x0]
 7  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0x7c]
Steps to reproduce this issue
On level 4 "underground lake" there is a magic barrier, if you dispel and go through the entrance there are 1 or more ylsides, the moment you attack them or they attack you, game crash to desktop.

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 30, 13:39
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-11284-2933086049
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 30, 13:39
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-11284-2933086049
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 30, 13:39
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-11284-2933086049
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 30, 13:39
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-11284-2933086049
#6
icon_reply.pngReply
Comment posted by
 Meblin
Jul 01, 21:23
Hi, I have exactly the same problem
#8
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jul 04, 10:17
This is a known issue, working on it.

The issue was updated with the following change(s):
  • This issue's title has been changed
  • This issue's description has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.
#9
icon_reply.pngReply
Comment posted by
 CrashBot
Jul 05, 07:54
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-42492-179919071
#10
icon_reply.pngReply
Comment posted by
 CrashBot
Jul 05, 07:54
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-42492-179919071
#11
icon_reply.pngReply
Comment posted by
 CrashBot
Jul 05, 07:54
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-42492-179919071
#12
icon_reply.pngReply
Comment posted by
 CrashBot
Jul 05, 07:54
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-42492-179919071
#13
icon_reply.pngReply
Comment posted by
 CrashBot
Today, 07:32
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-37872-934317524
#15
icon_reply.pngReply
Comment posted by
 CrashBot
Today, 07:32
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-37872-934317524
#14
icon_reply.pngReply
Comment posted by
 CrashBot
Today, 07:32
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-37872-934317524
#16
icon_reply.pngReply
Comment posted by
 CrashBot
Today, 07:32
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-37872-934317524