Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1512  -  [ADC768AB] arx.exe!ARX_PATH_UpdateAllZoneInOutInside() [paths.cpp:223]
Posted Nov 06, 2020 - updated Jan 14, 2021   Shortlink: http://arx.vg/1512
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #505 - "[178516F5] ARX_PATH_UpdateAllZoneInOutInside () Paths.cpp:265"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Paths.cpp:223: unreachable code

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x14007c832
 Stack pointer: 0x14f8d0


Callstack:
 arx.exe!0x14007c832
 arx.exe!0x1400b32b8
 arx.exe!0x1400b04d3
 arx.exe!0x1400b006e
 arx.exe!0x1400b85b0
 arx.exe!0x1400bfd79
 arx.exe!0x1401c2bb2
 arx.exe!0x1402b5015
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!ARX_PATH_UpdateAllZoneInOutInside() [paths.cpp : 223 + 0x1c]
 1  arx.exe!ArxGame::render() [arxgame.cpp : 2273 + 0xa]
 2  arx.exe!ArxGame::doFrame() [arxgame.cpp : 1331 + 0x0]
 3  arx.exe!ArxGame::run() [arxgame.cpp : 1254 + 0x0]
 4  arx.exe!runGame() [core.cpp : 290 + 0x0]
 5  arx.exe!utf8_main(int,char * * const) [startup.cpp : 210 + 0x0]
 6  arx.exe!WinMain [windowsmaingui.cpp : 48 + 0xe]
 7  arx.exe!__tmainCRTStartup [crtexe.c : 618 + 0x15]
Steps to reproduce this issue
Nothing entered.

#4
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 06, 09:13
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-15788-1263915511
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 06, 09:13
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-15788-1263915511
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 06, 09:13
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-15788-1263915511
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 06, 09:13
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-15788-1263915511
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jan 14, 02:39
This is an ancient development snapshot.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.