Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1514  -  [593979A] arx.exe!ARX_CHANGELEVEL_Pop_IO() [ChangeLevel.cpp:2224]
Posted Nov 11, 2020 - updated Jan 14, 2021   Shortlink: http://arx.vg/1514
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #818 - "[14529FB2] arx.exe!ARX_CHANGELEVEL_Pop_IO() [changelevel.cpp:2326]"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Unhandled exception

Exception code: Unknown error (3765269347).

 Instruction address: 0x7ff986923b29
 Stack pointer: 0x1ed717c1b0


Callstack:
 KERNELBASE.dll!RaiseException()
 VCRUNTIME140.dll!_CxxThrowException()
 MSVCP140.dll!void __cdecl std::_Xlength_error(char const * __ptr64)()
 arx.exe!0x7ff63ee6f641
 arx.exe!0x7ff63ee917c8
 arx.exe!0x7ff63ee6ac85
 arx.exe!0x7ff63edc8274
 arx.exe!0x7ff63edbc55b
 arx.exe!0x7ff63ee7e2e8
 arx.exe!0x7ff63edc39e8
 arx.exe!0x7ff63edc9ea3
 arx.exe!0x7ff63edcaf14
 arx.exe!0x7ff63ed65689
 arx.exe!0x7ff63eca54c4
 arx.exe!0x7ff63ecba13e
 arx.exe!0x7ff63edb418a
 arx.exe!0x7ff63ef2e05a
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
  3  arx.exe!std::vector<audio::OpenALSource *,std::allocator<audio::OpenALSource *> >::_Xlength [vector : 1671 + 0xd]
  4  arx.exe!std::vector<TWEAK_INFO,std::allocator<TWEAK_INFO> >::_Resize_reallocate<std::_Value_init_tag>(unsigned __int64,std::_Value_init_tag const &) [vector : 1135 + 0x5]
  5  arx.exe!std::vector<TWEAK_INFO,std::allocator<TWEAK_INFO> >::resize(unsigned __int64) [vector : 1194 + 0x0]
  6  arx.exe!ARX_CHANGELEVEL_Pop_IO [ChangeLevel.cpp : 2224 + 0x0]
  7  arx.exe!convertToValidIO [ChangeLevel.cpp : 193 + 0x0]
  8  arx.exe!ConvertToValidIO<64> [ChangeLevel.cpp : 197 + 0xc6]
  9  arx.exe!ARX_CHANGELEVEL_Pop_Player [ChangeLevel.cpp : 1652 + 0x8]
 10  arx.exe!ARX_CHANGELEVEL_PopLevel [ChangeLevel.cpp : 2500 + 0xb]
 11  arx.exe!ARX_CHANGELEVEL_Load(fs::path const &) [ChangeLevel.cpp : 2664 + 0x24]
 12  arx.exe!ARX_LoadGame(SaveGame const &) [MenuWidgets.cpp : 132 + 0x0]
 13  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1221 + 0x0]
 14  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0xa5]
 15  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
 16  arx.exe!__scrt_common_main_seh [exe_common.inl : 288 + 0x21]
Steps to reproduce this issue
Nothing entered.

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 18:22
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-5088-1544883665
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 18:22
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-5088-1544883665
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 18:22
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-5088-1544883665
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 18:22
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-5088-1544883665
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jan 14, 02:51
Please attach the save file that causes this crash. You can find the saves under your user directory - %USERPROFILE%\Saved Games\Arx Libertatis by default for newer versions of Windows.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.