Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #311  -  You can definitly loose Gem Dealer Papers !
Posted Jun 29, 2012 - updated Jul 02, 2012   Shortlink: http://arx.vg/311
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Not a bug" and resolution "NOT AN ISSUE".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    NOT AN ISSUE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
This bug occurs When you have to give the Gem Dealer Papers and Signed Authorization to the 3 Goblin Lords.

If you give firstly the Gem Dealer Papers (and do not have the Written Authorization signed), the paper is (always) given (so lost). If you leave the area (e.g. to make the paper signed) and return to the gate, Am Shaggar won't be able to give it (he says something like "it's too early").
Steps to reproduce this issue
  1. Have the Gem Dealers Papers and the written (not signed) Authorization on you.
  2. Go to the gate to leave the goblin area.
  3. Give the Gem Dealers Papers (it will vanish from your inventory), try to give the written authorization.
  4. Go back to the tavern and give the authorization paper to Polxsius.
  5. Return to the gate and try to give the signed authorization, you are now stucked...


You should try also the give firstly the Signed authorization, and see if the bug occurs.

#2
icon_reply.pngReply
Comment posted by
 Keyhaku
Jun 29, 13:34
I think the expected behaviour is that the papers (both) should only disappear if you are accepted. It's definitly a bug since the gem dealers papers disappear even if you are not accepted.
#3
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jul 01, 21:08
I cannot reproduce this.

SPOILER: The correct behavior is that the gem dealer license / authorization each disappear immediately, but the goblins remember it forever that you have given the paper - and you can give the papers in either ordewr. Alternatively you can bribe the goblin with 300 gold.

If the player says "Not now!" or "I'll do that later" while you try to give signed authorization it means that the the goblin is busy (probably hasn't finished talking yet - he mumbles for a bit). Wait for the goblin to complete it's speech and you should be able to pass. Please let us know if this works.

If this doesn't work, are you using the demo or full game? If using the full game, are you sure you applied the 1.21 patch before installing Arx Libertatis?
#5
icon_reply.pngReply
Comment posted by
 Guest user
icon_reply.pngJul 02, 14:39, in reply to comment #3
Ah indeed, maybe the lord goblin was mumbling or something, I have to admit that I didn't wait too long, tried to give the Auth 4 or 5 times, then reloaded a previous save.

I'm playing with the full game though, with the 1.21 patch applied.
#6
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jul 02, 15:46
Cool that it works

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to NOT AN ISSUE.