Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #581  -  Wrong weapon attachment when saving in combat mode
Posted Nov 11, 2013 - updated Jun 21, 2017   Shortlink: http://arx.vg/581
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Daniel Scharrer
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png next
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
When saving while in combat mode, the weapon will still be attached to the player's hand instead of back after loading, even thoughthe combat mode is cleared when loading.

Either the combat mode should be restored or the weapon should be attached to the correct position.
Steps to reproduce this issue
  • Enter combat mode (TAB)
  • Quicksave (F5)
  • Quickload (F9)

#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jun 21, 14:37
Fix in commit 976cf4b.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.