Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #706  -  Main menu screen cursor uncontrollable
Posted Jan 26, 2015 - updated Feb 15, 2016   Shortlink: http://arx.vg/706
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Always
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
On both of the latest versions of Arx Libertatis (I haven't tried any previous versions) I can't even progress past the main menu because the cursor is insanely sensitive. I've tried altering the mouse sensitivity both from the cfg.ini file (because I can't select the in-game options) and from the control panel, but neither option changes it at all.

I have the Steam version of Arx Fatalis and Windows 8.1 Pro 64xbit.
Steps to reproduce this issue
Nothing entered.

#1
icon_reply.pngReply
Comment posted by
 Guest user
Feb 01, 21:39
I am getting the same problem.
#2
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Feb 11, 10:25
Hi,
  1. "latest versions of Arx Libertatis" - just to be sure, that's 1.1.2, right?
  2. What kind of device are you using for mouse input? I've noticed problems under VirtualBox which afaik simulates an absolute pointer input device (like a touch screen). I haven't been able to reproduce any problems with relative pointer devices (aka actual mice).
  3. Does this happen with both fullscreen and windowed mode? You can toggle between them using Alt+Enter.
  4. Does this build change anything: arx-libertatis-sdl2-windows.zip (edit: latest development snapshots now also use SDL2) (run arx.exe - you might need to copy the files to you existing arx install)
#3
icon_reply.pngReply
Comment posted by
 Guest user
icon_reply.pngFeb 25, 00:21, in reply to comment #2
Hello, this is the OP.

1 Yes, version 1.2.2 "Rhaa Movis". 2 I have a "Logitech B110 Optical USB Mouse". 3 It happens in fullscreen mode, but switching to windowed mode appears to fix it. Thanks! 4 That build works perfectly, even in fullscreen mode! Thanks!

#6
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Feb 15, 00:36
SDL 2 will be the default for the next release, so this should be fixed.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.