Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #829  -  Doesn't work with german Steam version
Posted Apr 09, 2016 - updated Apr 08, 2017   Shortlink: http://arx.vg/829
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Always
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
Hi, I tried to run german Steam version with Arx Libertatis for Linux. Starting the installer there is an error, that files are wrong or missing. I then tried to rename files, because I assumed, that there might be a lower-case - capital-letter problem under Linux, I even compared the english version from gog (which I own too) with the german Steam version - nothing worked. Is this problem known and is there a way solving it ?

have a great day Torsten
Steps to reproduce this issue
start 'arx-install-data --gui' choosing install folder getting error message

#1
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 09, 16:48
It works fine here.

How did you install Arx from Steam - Windows / Wine / console / steamcmd?

Please attach the complete log from arx-install-data - the error message should include a path to the log file when using --gui (otherwise just post the complete output).
#2
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 09, 17:06
Hm, but it installs the english version of the files instead of the german one (steam seems to download both, as speech.pak/loc.pak and speech_default.pak/loc_default.pak).

Still, I'd like to know what error you are seeing since I don't get it here.
#5
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 08, 19:50
Hi,

I fixed the arx-install-data script to select the correct language for Steam installs. If you still have any issues with the latest version of the script, please provide the full log output.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.