Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Crash report #1250  -  [3428980A] ig7icd64.dll!RegisterProcTableCallback()
Posted Aug 13, 2018 - updated Oct 03, 2018   Shortlink: http://arx.vg/1250
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Issue details
  • Type of issue
    Crash report
  • Status
     
    New
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     BerkyBurr
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    Not determined
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png 1.2
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Exception code: ACCESS_VIOLATION

 Instruction address: 0x7ffe9a96ab6a
 Memory accessed: 0x8
 Stack pointer: 0x14f700


Callstack:
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!DrvSetLayerPaletteEntries()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!DrvSwapBuffers()
 ig7icd64.dll!DrvSwapBuffers()
 OPENGL32.dll!wglSwapBuffers()
 gdi32full.dll!SwapBuffers()
 arx.exe!0x1400b6237
 arx.exe!0x1400b5c5e
 arx.exe!0x1400bdc7b
 arx.exe!0x1400c492a
 arx.exe!0x1401b90c2
 arx.exe!0x1402a6cf5
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
  9  arx.exe!ArxGame::doFrame() [arxgame.cpp : 1311 + 0x0]
 10  arx.exe!ArxGame::run() [arxgame.cpp : 1197 + 0x0]
 11  arx.exe!runGame() [core.cpp : 268 + 0x0]
 12  arx.exe!utf8_main(int,char * * const) [startup.cpp : 164 + 0x0]
 13  arx.exe!WinMain [windowsmaingui.cpp : 48 + 0xe]
 14  arx.exe!__tmainCRTStartup [crtexe.c : 618 + 0x15]
Steps to reproduce this issue
This is the same crash that has happened for me that I previously reported about 20 hours ago. (arx/issues/1249)

I experienced the mouse bug with Arx Libertatis 1.1.2 and choosing D3L 9 or enabling 'Override High DPI' both failed to fix my issue. I found some advice online that led me to try the development snapshots.

After getting the most recent snapshot the game experienced a crash (which I reported arx/issues/1249) when I tried to start a new game or load a previous save. I reinstalled Arx Fatalis and tried it again (I am running a steam version of the game), it changed nothing.

I have tried every single development snapshot up until the most recent (which is dated 2018-08-13) from the archives and the problem starts to happen after arx-libertatis-1.2-dev-2017-10-18 version.

I will continue playing on this version, but would like to know what the issue is that is keeping me from updating to the newer versions of the snapshot.

#1
icon_reply.pngReply
Comment posted by
 BerkyBurr
Aug 13, 11:05
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-13076-3917452172
#3
icon_reply.pngReply
Comment posted by
 BerkyBurr
Aug 13, 11:05
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-13076-3917452172
#5
icon_reply.pngReply
Comment posted by
 BerkyBurr
Aug 13, 11:05
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-13076-3917452172
#4
icon_reply.pngReply
Comment posted by
 BerkyBurr
Aug 13, 11:05
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-13076-3917452172
#8
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Aug 16, 23:44
Hi, thanks for the detailed report!

So the backtrace makes this look like it's most likely a driver issue - definitely try updating to the latest video driver for your integrated intel graphics if you haven't already.

But something must have changed between 1.2-dev-2017-10-18 (commit e3dec1a4bbd0173974086217d9d3dbf551b1f862) and 1.2-dev-2017-12-02 (commit efddfd88c6cc9b12654c3d9fc728fe042b85d67a) that causes this to happen.

Does it crash immediately every time you start a new game or load a save?

Under "Renderer settings", try setting "Alpha Cutout AA" to "Disabled" and check if that helps. Also try disabling the "Antialias" option (and restart the game!).
#9
icon_reply.pngReply
Comment posted by
 BerkyBurr
icon_reply.pngAug 17, 15:16, in reply to comment #8
The crash is immediate on new game and after the loading screen when loading saved games. My drivers are up to date and I have also tried with my antivirus turned off.

After following your instructions (and testing with only 'Alpha Cutout AA' disabled, only 'Antialias' disabled and both of them disable) "Alpha Cutout AA" seems to be the culprit. As only using Antialias on 'unlimited' and the other disabled, the issue is fixed.

So, Alpha Cutout AA on 'Disabled' fixes the issue.

Daniel Scharrer wrote:
Hi, thanks for the detailed report!

So the backtrace makes this look like it's most likely a driver issue -
definitely try updating to the latest video driver for your integrated
intel graphics if you haven't already.

But something must have changed between 1.2-dev-2017-10-18 (commit
e3dec1a4bbd0173974086217d9d3dbf551b1f862) and 1.2-dev-2017-12-02 (commit
efddfd88c6cc9b12654c3d9fc728fe042b85d67a) that causes this to happen.

Does it crash immediately every time you start a new game or load a save?

Under "Renderer settings", try setting "Alpha Cutout AA" to "Disabled" and
check if that helps. Also try disabling the "Antialias" option (and restart
the game!).