Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1532  -  [B7B146FA] ig7icd64.dll!RegisterProcTableCallback()
Posted Mar 19, 2021 - updated Apr 15, 2021   Shortlink: http://arx.vg/1532
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1152 - "[67D3EFD2] ig7icd64.dll!RegisterProcTableCallback()"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Exception code: ACCESS_VIOLATION

 Instruction address: 0x7ffb7c59ab6a
 Memory accessed: 0x8
 Stack pointer: 0x52d66ff140


Callstack:
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!DrvSetLayerPaletteEntries()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!RegisterProcTableCallback()
 ig7icd64.dll!DrvSwapBuffers()
 ig7icd64.dll!DrvSwapBuffers()
 OPENGL32.DLL!wglSwapBuffers()
 gdi32full.dll!SwapBuffers()
 SDL2.dll!SDL_DYNAPI_entry()
 arx.exe!0x7ff6e53d58cf
 arx.exe!0x7ff6e53ea13e
 arx.exe!0x7ff6e54e418a
 arx.exe!0x7ff6e565e05a
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()


Steps to reproduce this issue
Started a new game.

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 19, 16:05
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-1416-218139498
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 19, 16:05
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-1416-218139498
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 19, 16:05
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-1416-218139498
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 19, 16:05
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-1416-218139498
#6
icon_reply.pngReply
Comment posted by
 Guest user
Mar 19, 16:17
I think this is my one. Tried running Arx Fatalis with the latest dev build. Lenovo Thinkpad with an i5 3320m CPU and Intel HD4000 graphics, windows 10 64-bit. Whereas the latest official release seems to work fine, the latest two dev builds both suffer the same crash issue. (they appear to actually crash on the intro if it is left to load instead of skipping)
#7
icon_reply.pngReply
Comment posted by
 Guest user
Mar 23, 00:17
Okay, update: after searching "illegal storage access arx" I came across another error where someone was having issues with OpenGL render settings. I started flipping switches and got it to work! It seems after some trial and error that the setting causing problems is "Alpha Cutout AA"; setting it to Crisp causes the game to crash when attempting to render anything outside the menu. Any other setting seems to work fine.
#8
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 15, 21:40
Thanks for the detective work - we will add a workaround.

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.