Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1362  -  [C49DC3C1] arx.exe!D3D9VertexBuffer::lock() [d3d9vertexbuffer.h:136]
Posted Jun 12, 2019 - updated Jun 20, 2019   Shortlink: http://arx.vg/1362
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #274 - "[4B61E591] arx.exe!D3D9VertexBuffer<SMY_VERTEX>::lock() d3d9vertexbuffer.h(136) "
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png x86
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Callstack:
  arx.exe!0x54591c 
  arx.exe!0x4f01c5 
  arx.exe!0x61cffa 
  arx.exe!0x61a83e 
  arx.exe!0x4dd611 
  kernel32.dll!BaseThreadInitThunk() 
  ntdll.dll!RtlInitializeExceptionChain() 
  ntdll.dll!RtlInitializeExceptionChain() 
Symbols:
 0  arx.exe!D3D9VertexBuffer<SMY_VERTEX>::lock(Flags<BufferFlag>,unsigned __int64,unsigned __int64) [d3d9vertexbuffer.h : 136 + 0x2b]
 1  arx.exe!ComputePortalVertexBuffer() [mesh.cpp : 4299 + 0x1e]
 2  arx.exe!ArxGame::InitDeviceObjects() [arxgame.cpp : 2293 + 0x0]
 3  arx.exe!ArxGame::onRendererInit(RenderWindow &) [arxgame.cpp : 2337 + 0x0]
 4  arx.exe!D3D9Window::restoreObjects() [d3d9window.cpp : 337 + 0x22]
 5  arx.exe!D3D9Window::tick() [d3d9window.cpp : 182 + 0x0]
 6  arx.exe!ArxGame::Run() [arxgame.cpp : 559 + 0x0]
 7  arx.exe!runGame() [core.cpp : 842 + 0x0]
 8  arx.exe!WinMain [core.cpp : 875 + 0x0]
 9  arx.exe!__tmainCRTStartup [crtexe.c : 547 + 0x25]
Registers:
  EAX:00000000  EBX:64822D1E  ECX:00000000  EDX:0149FAA4  ESI:00000500  EDI:02D09AD8
  CS:EIP:0023:778A98D5
  SS:ESP:002B:0149FFDC  EBP:0149FFEC
  DS:002B  ES:002B  FS:0053  GS:002B
  Flags:00010246


Steps to reproduce this issue
Nothing entered.

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 12, 16:54
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-4664-2011397657
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 12, 16:54
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-4664-2011397657
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 12, 16:54
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-4664-2011397657
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 12, 16:54
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-4664-2011397657
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jun 20, 11:25
Arx Libertatis 1.0.2 is no longer supported, please try a newer version.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.