Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1448  -  [341D0E97] arx.exe!OpenGLRenderer::initialize() [OpenGLRenderer.cpp:111]
Posted Apr 17, 2020 - updated May 18, 2020   Shortlink: http://arx.vg/1448
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1398 - "[D4096F26] arx.exe!OpenGLRenderer::initialize() [OpenGLRenderer.cpp:111]"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Exception code: ACCESS_VIOLATION

 Instruction address: 0x7ff6edd73be1
 Memory accessed: 0x0
 Stack pointer: 0x9a950fea80


Callstack:
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 arx.exe!0x7ff6edb7ec9d
 arx.exe!0x7ff6edca97f0
 arx.exe!0x7ff6edca9b1e
 arx.exe!0x7ff6edaf0ff6
 arx.exe!0x7ff6edaef642
 arx.exe!0x7ff6edaff074
 arx.exe!0x7ff6edb074bd
 arx.exe!0x7ff6edbff0ca
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 2  arx.exe!OpenGLRenderer::initialize() [OpenGLRenderer.cpp : 111 + 0x0]
 3  arx.exe!SDL2Window::createWindowAndGLContext(char const *) [SDL2Window.cpp : 301 + 0x0]
 4  arx.exe!SDL2Window::initialize() [SDL2Window.cpp : 366 + 0xf]
 5  arx.exe!ArxGame::initWindow(RenderWindow *) [ArxGame.cpp : 433 + 0xa]
 6  arx.exe!ArxGame::initialize() [ArxGame.cpp : 221 + 0x32]
 7  arx.exe!runGame() [Core.cpp : 241 + 0x3]
 8  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 168 + 0x0]
 9  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
Steps to reproduce this issue
Nothing entered.

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 17, 01:07
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-4848-475655153
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 17, 01:07
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-4848-475655153
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 17, 01:07
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-4848-475655153
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 17, 01:07
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-4848-475655153
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
May 18, 19:57
Please update your graphics drivers.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.