Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1503  -  [7046E8B2] aarx.exe!Trail::Render() [Trail.cpp:117]
Posted Oct 17, 2020 - updated Nov 12, 2020   Shortlink: http://arx.vg/1503
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1468 - "Shooting with the bow implementation crashes the game"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Trail.cpp:117: m_positions.size() >= size_t(std::ceil(n)) 2

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x7ff661f1100e
 Stack pointer: 0xb9822ff280


Callstack:
 arx.exe!0x7ff661f1100e
 arx.exe!0x7ff661ed8e11
 arx.exe!0x7ff661e98fca
 arx.exe!0x7ff661e99956
 arx.exe!0x7ff661e960d2
 arx.exe!0x7ff661ea7cfe
 arx.exe!0x7ff661f9f01a
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!Trail::Render() [Trail.cpp : 117 + 0x1a]
 1  arx.exe!SpeedSpell::Update() [SpellsLvl03.cpp : 129 + 0x0]
 2  arx.exe!ArxGame::renderLevel() [ArxGame.cpp : 1948 + 0x122]
 3  arx.exe!ArxGame::render() [ArxGame.cpp : 2082 + 0x0]
 4  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1304 + 0x0]
 5  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0xa5]
 6  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
Steps to reproduce this issue
casting speed spell in castle while going up the stairs to the right of the entrance


#1
icon_reply.pngReply
Comment posted by
 CrashBot
Oct 17, 01:25
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-5544-1394815502
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Oct 17, 01:25
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-5544-1394815502
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Oct 17, 01:25
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-5544-1394815502
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Oct 17, 01:25
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-5544-1394815502
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Oct 19, 21:21
Please upgrade to the latest development snapshot - this has been fixed for a while now.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.
#8
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 09, 23:32
ylsides make my game crash when they come near me?

#11
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 09, 23:32
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-6008-2935736179
#9
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 09, 23:32
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-6008-2935736179
#10
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 09, 23:32
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-6008-2935736179
#12
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 09, 23:32
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-6008-2935736179
#15
icon_reply.pngReply
Comment posted by
 Bubbels
Nov 10, 03:20
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-6260-3944213472
#13
icon_reply.pngReply
Comment posted by
 Bubbels
Nov 10, 03:20
fighting ylsides in their lair
#14
icon_reply.pngReply
Comment posted by
 Bubbels
Nov 10, 03:20
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-6260-3944213472
#16
icon_reply.pngReply
Comment posted by
 Bubbels
Nov 10, 03:20
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-6260-3944213472
#17
icon_reply.pngReply
Comment posted by
 Bubbels
Nov 10, 03:20
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-6260-3944213472
#19
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:46
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-20812-960137061
#20
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:46
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-20812-960137061
#18
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:46
Ysilde drew weapon on me smileys/4.png
#22
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:46
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-20812-960137061
#21
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:46
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-20812-960137061
#23
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:49
Ysilde attacked me again. smileys/4.png
#24
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:49
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-15600-3043000721
#26
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:49
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-15600-3043000721
#25
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:49
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-15600-3043000721
#27
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 03:49
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-15600-3043000721
#28
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 20:13
Cast Haste standing alone in level 6. One of the effects of the spell seems to cause the crash.
#29
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 20:13
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-9892-3076535189
#31
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 20:13
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-9892-3076535189
#30
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 20:13
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-9892-3076535189
#32
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 11, 20:13
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-9892-3076535189
#34
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 12, 21:48
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-8284-3542368430
#33
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 12, 21:48
Fighting Ylside men in the Arx Castle. Something they do near the start of the battle causes a crash like 80% of the time.
#35
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 12, 21:48
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-8284-3542368430
#36
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 12, 21:48
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-8284-3542368430
#37
icon_reply.pngReply
Comment posted by
 CrashBot
Nov 12, 21:48
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-8284-3542368430