Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1536  -  [B71EA432] arx.exe!getLocalised() [Localisation.cpp:425]
Posted Mar 29, 2021 - updated Jun 05, 2021   Shortlink: http://arx.vg/1536
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1479 - "[2DFF4FEC] arx.exe!getLocalised() [Localisation.cpp:425]"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Localisation.cpp:425: name.find_first_of("ABCDEFGHIJKLMNOPQRSTUVWXYZ[1]") == std::string::npos

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x7ff6b8e167af
 Stack pointer: 0x94440ff2b0


Callstack:
 arx.exe!0x7ff6b8e167af
 arx.exe!0x7ff6b8ec9906
 arx.exe!0x7ff6b8e08bf4
 arx.exe!0x7ff6b8e09126
 arx.exe!0x7ff6b8e058a2
 arx.exe!0x7ff6b8e1a2fe
 arx.exe!0x7ff6b8f1201a
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!getLocalised(std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &) [Localisation.cpp : 425 + 0x25]
 1  arx.exe!ARX_SPEECH_Render [Notification.cpp : 151 + 0x1d]
 2  arx.exe!ArxGame::renderLevel() [ArxGame.cpp : 1946 + 0x7d]
 3  arx.exe!ArxGame::render() [ArxGame.cpp : 2045 + 0x0]
 4  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1267 + 0x0]
 5  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0xa5]
 6  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
Steps to reproduce this issue
Nothing entered.

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 29, 14:31
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-16092-1182072767
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 29, 14:31
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-16092-1182072767
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 29, 14:31
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-16092-1182072767
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 29, 14:31
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-16092-1182072767
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 05, 17:13
Please use and up to date development snapshot - this has been fixed for a long time.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.
#9
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 10, 11:30
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-28700-1985178053
#8
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 10, 11:30
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-28700-1985178053
#10
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 10, 11:30
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-28700-1985178053
#11
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 10, 11:30
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-28700-1985178053
#12
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 11, 03:03
cant load level 2 at all crashes the game

#14
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 11, 03:03
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-4996-1834207903
#13
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 11, 03:03
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-4996-1834207903
#15
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 11, 03:03
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-4996-1834207903
#16
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 11, 03:04
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-4996-1834207903
#17
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 16, 18:04
Game started correctly, it only crashed when loading any save, neither quicksave or regular saved doesn't matter.
#18
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 16, 18:04
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-1136-2777665873
#19
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 16, 18:04
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-1136-2777665873
#20
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 16, 18:04
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-1136-2777665873
#21
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 16, 18:04
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-1136-2777665873
#22
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 28, 16:26
Crashes after it completes the load screen for the goblin zone from the outpost.
#23
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 28, 16:26
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-6868-2005480427
#24
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 28, 16:26
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-6868-2005480427
#25
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 28, 16:26
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-6868-2005480427
#26
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 28, 16:26
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-6868-2005480427
#28
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 05, 03:23
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-12772-317761614
#27
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 05, 03:23
Hapens whenever I try to load any save. I am really early in the game and have yet to leave the goblins.
#29
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 05, 03:23
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-12772-317761614
#30
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 05, 03:23
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-12772-317761614
#31
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 05, 03:23
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-12772-317761614