Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
task_small.png
CLOSED  Task #435  -  Ship OpenAL Soft with the Windows installer
Posted Dec 06, 2012 - updated Jan 30, 2013   Shortlink: http://arx.vg/435
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Task
  • Status
     
    Fixed
  • Assigned to
     SebastienLussier
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    3 hours
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Always
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.1
Issue description
Good job so far, but I missing some sounds... like footsteps or rune casting.

#1
icon_reply.pngReply
Comment posted by
 Guest user
Dec 06, 00:35
Oh, and I have 1.0.3 and I have started a new game. German Version from Steam.

#2
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 06, 00:36
Strange, seems to be working fine for me. Other sounds work, right? Are the footsteps and casting sounds always missing or only sometimes?

Can you please post your cfg.ini and arx.log? It's located in:

  • XP: '<profile>\My Documents\My Games\Arx Libertatis'
  • Vista and up: '<profile>\Saved Games\Arx Libertatis'
  • Linux: '~/.local/share/arx/' and '~/.config/arx/'
  • OS X: '~/Library/Application Support/ArxLibertatis/'


Also, this might be a duplicate of Bug report 415 - ambient sounds
#3
icon_reply.pngReply
Comment posted by
 Guest user
Dec 06, 07:50
The sounds are missing always =/

Here is my log:
  1. [I] Core:650 Starting Arx Libertatis 1.0.3
  2. [I] D3D9Window:140 Using Win32 windowing
  3. [I] D3D9Renderer:251 Using Direct3D 9
  4. [I] D3D9Renderer:252 Device: NVIDIA GeForce GTX 570
  5. [I] D3D9Renderer:255 Driver: nvd3dumx.dll
  6. [I] D3D9Renderer:264 Version: 9.18.13 build 697
  7. [I] D3D9Window:162 Using Win32 windowing
  8. [I] DInput8Backend:301 Using DirectInput 8
  9. [I] OpenALBackend:128 Using Software 1.1 with EFX
  10. [I] PakReader:544 Loaded PAK "E:\Spiele\Arx Libertatis\data.pak"
  11. [I] PakReader:544 Loaded PAK "E:\Spiele\Arx Libertatis\loc.pak"
  12. [I] PakReader:544 Loaded PAK "E:\Spiele\Arx Libertatis\data2.pak"
  13. [I] PakReader:544 Loaded PAK "E:\Spiele\Arx Libertatis\sfx.pak"
  14. [I] PakReader:544 Loaded PAK "E:\Spiele\Arx Libertatis\speech.pak"
  15. [I] PakReader:608 Added dir "E:\Spiele\Arx Libertatis\graph"
  16. [I] PakReader:608 Added dir "E:\Spiele\Arx Libertatis\misc"
  17. [I] SaveGame:153 found save (quicksave) 2012-12-06 0:54:32
  18. [I] SaveGame:153 found save "adventureFAN" 2012-12-06 0:00:41
  19. [I] SaveGame:153 found save (quicksave) 2012-12-06 0:33:26
  20. [I] SaveGame:153 found save (quicksave) 2012-12-06 0:23:19
  21. [I] Localisation:123 Using language from config file: deutsch
  22. [I] ScriptEvent:540 scripting system initialized with 176 commands and 186 suppressions
  23. [I] Text:375 Loaded font "misc/arx_default.ttf" with sizes 75, 41, 26, 52, 27, 27, 27
  24. [I] Core:612 Launching splash screens.
  25. [I] Core:824 Initialized Arx Fatalis (full game)
  26. [I] LoadLevel:658 Loading Level "graph/levels/level10/level10.dlf"
  27. [I] LoadLevel:1162 Done loading level
  28. [I] CinematicLoad:138 loading cinematic "graph/interface/illustrations/introduction.cin"
  29. [I] ArxGame:522 changed fullscreen resolution to 1440x900@32
  30. [I] DSoundBackend:150 Using DirectSound without EAX
  31. [I] LoadLevel:658 Loading Level "graph/levels/level1/level1.dlf"
  32. [I] LoadLevel:1162 Done loading level
  33. [I] LoadLevel:658 Loading Level "graph/levels/level1/level1.dlf"
  34. [I] LoadLevel:1162 Done loading level
  35. [I] CinematicLoad:138 loading cinematic "graph/interface/illustrations/akbaa_dream_c.cin"
  36. [I] OpenALBackend:128 Using Software 1.1 with EFX
  37. [I] OpenALBackend:128 Using Software 1.1 without EFX
  38. [I] OpenALBackend:128 Using Software 1.1 with EFX
  39. [I] LoadLevel:658 Loading Level "graph/levels/level1/level1.dlf"
  40. [I] LoadLevel:1162 Done loading level
  41. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:07:05
  42. [I] LoadLevel:658 Loading Level "graph/levels/level1/level1.dlf"
  43. [I] LoadLevel:1162 Done loading level
  44. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:08:13
  45. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:09:08
  46. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:09:37
  47. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:10:04
  48. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:10:45
  49. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:11:39
  50. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:12:16
  51. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:13:07
  52. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:14:04
  53. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:16:28
  54. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:18:10
  55. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:19:51
  56. [I] LoadLevel:658 Loading Level "graph/levels/level12/level12.dlf"
  57. [I] LoadLevel:1162 Done loading level
  58. [I] CinematicLoad:138 loading cinematic "graph/interface/illustrations/ylside.cin"
  59. [I] SaveGame:153 found save (quicksave) 2012-12-06 1:21:25
  60. [I] Core:4042 Clean shutdown
  61. [W] D3D9Window:71 D3DDevice object is still referenced
  62. [I] ArxGame:538 Application window is being destroyed
#4
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 07, 13:16
A file was uploaded. 32-bit OpenAL32.dllicon_open_new.png
#5
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 07, 13:16
A file was uploaded. 64-bit OpenAL32.dllicon_open_new.png
#6
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 07, 13:21
Hm, the log doesn't show anything that went wrong...

Can you please download one of the two OpenAL32.dll files I attached (you need the 32-bit one for 32-bit Arx Libertatis and the 64-bit one for 64-bit Arx Libertatis) and put it where you installed Arx Libertatis (it needs to be in the same directory as arx.exe). If everything went OK the log should say "Using OpenAL Soft 1.1 ALSOFT 1.15".

If that doesn't help, you could try the "Direct Sound" backend under Options -> Audio Settings.
#7
icon_reply.pngReply
Comment posted by
 Guest user
Dec 07, 13:32
Yes! With the 64bit-DDL it works! =D Thank very much! Much more atmosphere =]

Hope this project never stops!
#9
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 07, 13:36
Good to know. We'll see about shipping that OpenAL implementation with the installer then.
#13
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 08, 12:08
Related: Feature request 379 - Allow to choose the OpenAL device/driver
#16
icon_reply.pngReply
Comment posted by
 SebastienLussier
Jan 30, 05:15
The game installer now contains the OAL soft dlls

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Being worked on to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from SebastienLussier to Not being worked on.
  • Time spent on this issue, from No time spent to 3 hours.
  • This issue's progression has been updated to 100 percent completed.