Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #718  -  character at each “LineBreak” in Chinese
Posted Feb 26, 2015 - updated Mar 08, 2015   Shortlink: http://arx.vg/718
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    User interface
  • Resolution
    RESOLVED
  • Priority
    Regression
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
I used an unoffical text-only translation. Uh, there is no space characters between Chinese, so I only get “LineBreak” in game. In Arx Libertatis 1.1.2, characters near by “LineBreak” is "??". It's a little better in latest git version, just missing one character at the end of “LineBreak”. I try to fix it and I did it, but I don't know whether it is right.

src / gui / Text.cpp line 163 : itLastLineBreak = next;

I change it to : itLastLineBreak = it;

Sorry for my bad english ...
Steps to reproduce this issue
Nothing entered.

#1
icon_reply.pngReply
Comment posted by
 Guest user
Feb 26, 16:38
I can send you the translation by email ( manglesky@163.com ). If you need a font to test, you can find some opensource font :P