Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #790  -  Durability decreases too fast
Posted Dec 01, 2015 - updated Jan 13, 2018   Shortlink: http://arx.vg/790
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Daniel Scharrer
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Regression
  • Reproducability
    Often
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png 1.2
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
Items break quicker in AL 1.1+ than in AF 1.21
Steps to reproduce this issue
Take the bone at the start of the game.

The displayed durability starts out at 4.

When hitting the walls or other static objects (make sure to get a good hit), the displayed durability should go down as follows
  1. 3
  2. 1
  3. broken


With AL 1.1 or newer the bone breaks on the first hit when the attack fully charged.

This issue does not exits in Arx Libertatis 1.0.3.

#3
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Dec 01, 18:39
A file was uploaded. Save file to reproduce the issue.icon_open_new.png This comment was attached:

Here is an even more extreme example. A single fully charged hit on the barrel breaks the sword even though it's at 25/50 durability. Same for the clubs that get auto-equipped when it breaks.
#9
icon_reply.pngReply
Comment posted by
 bsxf47
Jul 13, 19:14
Did this get fixed already? I just tried the save file with the newest code in the repo, and the short sword needed four fully charged hits to break. If I start a new game, bones need a few hits too.
#10
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jul 18, 20:09
Maybe - I just tried and couldn't reproduce the problem. IIRC there was some discussion on iirc about this around the time I posted this issue, maybe something came out of that.

I'll do some more testing to ensure that this is really fixed.
#12
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jan 13, 21:58
This will be fixed in the next development snapshot.

The issue was updated with the following change(s):
  • The custom field Fixed in has been updated, from Unknown to Arx Libertatis 1.2-dev.
  • This issue has been closed
  • The status has been updated, from New to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.