Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #826  -  [7BA8FAAC] arx.exe!0x14014eebe
Posted Apr 06, 2016 - updated Apr 06, 2016   Shortlink: http://arx.vg/826
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #439 - "[A34045DF] Save file corruption in defragmentation resulting in crash on load"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
new operator failed

Callstack:
  arx.exe!0x14014eebe 
  arx.exe!0x14014f05a 
  MSVCR100.dll!_callnewh() 
  MSVCR100.dll!malloc() 
  MSVCR100.dll!void * __ptr64 __cdecl operator new(unsigned __int64)() 
  arx.exe!0x140072c04 
  arx.exe!0x140072b79 
  arx.exe!0x1400729b1 
  arx.exe!0x14029c9c3 
  arx.exe!0x14029e0ce 
  arx.exe!0x14029f603 
  arx.exe!0x14014d4eb 
  arx.exe!0x14014e31c 
  arx.exe!0x1402565f7 
  arx.exe!0x140250fde 
  arx.exe!0x1402b1123 
  arx.exe!0x1400f8d4b 
  KERNEL32.DLL!BaseThreadInitThunk() 
  ntdll.dll!RtlUserThreadStart() 


Registers:
  RAX:00000000001E6250  RBX:000000009AB380E0  RCX:00000000001E6250  RDX:0000000000000000  RSI:0000000000276000  RDI:00000000400F8EBC
  CS:RIP:0033:9CC1C5B4
  SS:RSP:002B:000000000014FF90  RBP:0000000000000000
  DS:002B  ES:002B  FS:0053  GS:002B
  Flags:00000206


Steps to reproduce this issue
Changing Map from Kingdom of Arx (Castle) to City of Arx.

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 06, 00:36
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-5180-1071929700
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 06, 00:36
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-5180-1071929700
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 06, 00:36
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-5180-1071929700
#6
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 06, 06:41
There is not minidump here so we can't be sure, but this looks to have the same root cause.

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.