Arx Libertatis Bug Tracker
Please log in to bookmark issues
CLOSED  Bug report #185  -  Frame jumps causing the player to move much faster for a short time
Posted Mar 03, 2012 - updated Jul 14, 2013   Shortlink:
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
  • Assigned to
    Not assigned to anyone
  • Progress
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
  • Resolution
  • Priority
    Not determined
  • Reproducability
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.1
Issue description
There is a bug in the game's time handling code that causes the player to move very fast for a short time (or jump ahead almost instantly), usually right after the game is running very slow or almost freezing. This seems to happen on various configurations and is somewhat similar to the kind of lag that can be experienced in some multiplayer games.

For some, disabling/enabling VSync or other driver-specific settings can improve the situation somewhat. The jumps also seem to be worse and more frequent if the game is already running generally slow.


Also, this can cause the player to jump though areas that are supposed to trigger script events. Example:

The first time I talked with sister Chinkashh was by "f" on her. Then I tried leaving the room and she started the "well well a new face..." dialog.

This probably does not affect further gameplay.

The game lags often on my ASUS EeePC 1000H. This results in me "jumping" forward if during the lag I was pressing forward. Perhaps the problem is related to that fact. Perhaps I "ran through" the area that triggers the first dialog with her.

My computer has two cores. This/the lags might be multicore related.
Steps to reproduce this issue
Was able to reproduce once. Also happened when I was lag-jumping through the door area.

  1. Stand in front of open library door before having had this first conversation with Chinkashh
  2. Go forward and hope for a lag
  3. Doing things that load new data might help, for example casting spells while going forward.

Comment posted by
 Daniel Scharrer
Mar 04, 19:34
For me either disabling VSync (be sure to disable compositing too) or enabling triple buffering in the opengl driver (ATI binray driver) hides or at least mitigates this issue. The underlying timing bug is of course still there and needs to be fixed, but if you can do something similar with your GL driver it might at least get rid of those annoying time-jumps for now.

Strangely, I don't seem to be able to cause the jumps by quicksaving right now.
Comment posted by
Mar 06, 16:14
ASUS EeePC 1000H has Intel open source graphics drivers. The cause for the lags might be low CPU frequency.

I tried a branch that had a fix that would tie game speed to fps. This made the game slow down a lag-jumps would not happen any more. However the playing experience was much more painful. I nearly completed the game by now. I would probably not play the game if game speed was tied to FPS. smileys/2.png
Comment posted by
Nov 01, 15:39
This is a permanent issue for me; all movements in game can only be described as horizontal jumps to a non-controlable distance.

The example mentioned 'The first time I talked with sister Chinkashh ...' was even worse for me, with the auto-detection message only happening after I had met her several times on other concerns.

It eventually led to the storyline stopped in the Temple of Akbaa, where I first had ALL magic permanently disabled (which I could recover later) and no NPC interaction happening in the sacrifice room (which stays a permanent situation so far).

Comment posted by
 Guest user
Jan 25, 02:23
Want to report that I am also seeing this issue with Arx Lib. 1.0.3. It is intermittent with me, but definitely happens enough to concern me. I have a fairly fast rig: (2GHz i7, GTX 460-M). I haven't tried disabling VSYNC to see if that helps. Just wanted to report that this bug is for real.

Best way to describe it is that you are strolling along and then suddenly you are many paces away almost instantly. When you "warp" you hear all the footsteps that would take place played back very quickly. It is kind of surreal, actually.
Comment posted by
Jul 03, 02:14
A file was uploaded. Savegameicon_open_new.png This comment was attached:

In this area, i get frequent fps hitches triggering the bug in a debug build.
Comment posted by
 Daniel Scharrer
Jul 06, 16:20
A fix for this is available in the git sources and will be part of the upcoming 1.1 release.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Confirmed to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.