Arx Libertatis Bug Tracker
Please log in to bookmark issues
CLOSED  Bug report #293  -  Facing some kind of "lag" in-game.
Posted Jun 22, 2012 - updated Jun 22, 2012   Shortlink:
icon_info.png This issue is a duplicate of issue #185 - "Frame jumps causing the player to move much faster for a short time"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Bug report
  • Status
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
  • Priority
    Not determined
  • Reproducability
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Once in-game, there's a kind of lag that happens, pretty close to the famous lag one can face when playing on-line. For half a second, the game will suddenly slow down, almost stop, and then for another half a second the character will move really fast. Sometimes it is pretty light, my character will speed up slightly, sometimes the game freezes and then I am Flash for 3 full seconds. :D This mostly happens when passing over or close to things with which you can interact : characters, corpses, animals, etc. A similar bug has already been reported months ago, but it takes place much later in the game. In my case it happens as soon as I leave my cell and fight the guarding goblin. Also, I'm using an AMD Athlon 64 3000+. A single core processor. So this bug can't be related to the Dual and Quad core processors only. I'm using XP too. SP3. 32bits. Weird thing in my case is that Arx Fatalis was once running flawlessly on the same computer (nothing has been changed) and now it bugs. I've tried different things, nothing worked. It happens in Arx Fatalis 1.17, 1.21 and also Arx Libertatis. Even with the non-official patch (0.03? something like that).

Steps to reproduce this issue
Simply launch a new game, escape from your cell then continue playing, it should happen pretty rapidly. Of course, I can't guarantee this will occur on different computers. After all, it wasn't happening for me a few years ago.

Comment posted by
 Daniel Scharrer
Jun 22, 22:02
I don't think there is a need for multiple open bug reports of this and have updated the description in Bug report 185 - Frame jumps causing the player to move much faster for a short time to more general.

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.