Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #539  -  Map rendering glitches in OpenGL mode. See the attached screenshots.
Posted Aug 06, 2013 - updated Nov 16, 2014   Shortlink: http://arx.vg/539
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Dimoks
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Regression
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png 1.2
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Arx Libertatis 1.2-dev
Issue description
There are some map rendering glitches in OpenGL mode. See the attached screenshots.
Steps to reproduce this issue
Nothing entered.

#1
icon_reply.pngReply
Comment posted by
 Dimoks
Aug 06, 23:19
A file was uploaded.
Screenshot 1
Screenshot 1icon_open_new.png
#2
icon_reply.pngReply
Comment posted by
 Dimoks
Aug 06, 23:19
A file was uploaded.
Screenshot 2
Screenshot 2icon_open_new.png
#5
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Oct 17, 09:19
Possibly related crashes: Crash report 568 - [META] Crashes when using the map section in the player book
#6
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Mar 01, 05:13
So I don't forget: we figured out this was caused by the driver claiming non-power-of-two texture support while only providing partial support (no mipmaps, ...). We need to work around that and generally improve the power-of-tow textures fallback.
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Aug 27, 00:22
See http://aras-p.info/blog/2012/10/17/non-power-of-two-textures/ for possible workarounds.

Also, we need to fix our power-of-two fallback code: http://i.imgur.com/dzVwSVK.jpg
#11
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Aug 31, 10:57
This should be fixed in the current development code, can you confirm?
#12
icon_reply.pngReply
Comment posted by
 Dimoks
Sep 03, 12:29
Now the maps are displayed normally...
#13
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Nov 16, 04:42
This has been fixed in git for a while now.

The issue was updated with the following change(s):
  • The custom field Fixed in has been updated, from Unknown to Arx Libertatis Git.
  • The custom field OS has been updated to Unknown.
  • This issue has been closed
  • The status has been updated, from Ready for testing / QA to Fixed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • This issue's progression has been updated to 100 percent completed.