Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1498  -  [6D0F0992] arx.exe!Trail::Render() [Trail.cpp:117]
Posted Sep 09, 2020 - updated Sep 09, 2020   Shortlink: http://arx.vg/1498
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1468 - "Shooting with the bow implementation crashes the game"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Trail.cpp:117: m_positions.size() >= size_t(std::ceil(n)) 2

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x7ff697c2100e
 Stack pointer: 0x588f7edd0


Callstack:
 arx.exe!0x7ff697c2100e
 arx.exe!0x7ff697be8e11
 arx.exe!0x7ff697ba8fca
 arx.exe!0x7ff697ba9956
 arx.exe!0x7ff697ba60d2
 arx.exe!0x7ff697bb7cfe
 arx.exe!0x7ff697caf01a
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!Trail::Render() [Trail.cpp : 117 + 0x1a]
 1  arx.exe!SpeedSpell::Update() [SpellsLvl03.cpp : 129 + 0x0]
 2  arx.exe!ArxGame::renderLevel() [ArxGame.cpp : 1948 + 0x122]
 3  arx.exe!ArxGame::render() [ArxGame.cpp : 2082 + 0x0]
 4  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1304 + 0x0]
 5  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0xa5]
 6  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
Steps to reproduce this issue
Nothing entered.

#3
icon_reply.pngReply
Comment posted by
 CrashBot
Sep 09, 10:31
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-10108-2945452580
#1
icon_reply.pngReply
Comment posted by
 CrashBot
Sep 09, 10:31
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-10108-2945452580
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Sep 09, 10:31
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-10108-2945452580
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Sep 09, 10:31
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-10108-2945452580
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Sep 09, 20:24
Update yo game.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.