Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #158  -  Wrong skill requirement for lord Inut's bow
Posted Feb 12, 2012 - updated Jan 08, 2015   Shortlink: http://arx.vg/158
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Issue details
  • Type of issue
    Bug report
  • Status
     
    Confirmed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     nemyax
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Gameplay
  • Resolution
    Not determined
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Normal
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
I have 30 projectile, yet when I try to equip lord Inut's bow, which requires exactly 30, the game doesn't let me.

This bug appears to be due to inconsistency with the graph/obj3d/interactive/items/weapons/bow/bow.asl script, which has this check: PLAYER_SKILL_PROJECTILE < 30

graph/obj3d/interactive/items/weapons/bow_mx/bow_mx.asl on the other hand has: PLAYER_SKILL_PROJECTILE < 40
Steps to reproduce this issue
Nothing entered.

#12
icon_reply.pngReply
Comment posted by
 HelenWong
Jan 07, 00:32
When I open graph/obj3d/interactive/items/weapons/bow/bow.asl , the check is ^PLAYER_SKILL_PROJECTILE < 30, so I don't think it is the problem now? Maybe this bug is before the 1.21 patch?
#13
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Jan 08, 05:22
Lord Inut's bow entity class is actually bow_mx so the script file is:
 graph/obj3d/interactive/items/weapons/bow_mx/bow_mx.asl


The problem is that the skill requirement is altered from the regular bow but it still uses the normal "description_bow" string as the description. To fix this we will need to implement support for patching the script and localization files.