Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #821  -  [D1A9B2E1] arx.exe!Cedric_AnimCalcTranslation() [animationrender.cpp:241]
Posted Mar 18, 2016 - updated Apr 02, 2016   Shortlink: http://arx.vg/821
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #253 - "[9774F695] arx.exe!Cedric_AnimCalcTranslation() animationrender.cpp(243) "
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png x86
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Illegal storage access

Callstack:
  arx.exe!0x65785f 
  arx.exe!0x657b62 
  arx.exe!0x6369f6 
  arx.exe!0x519310 
  arx.exe!0x505659 
  arx.exe!0x61bce4 
  arx.exe!0x614797 
  arx.exe!0x4e017f 
  kernel32.dll!RegisterWaitForInputIdle() 
Symbols:
 0  arx.exe!Cedric_AnimCalcTranslation [animationrender.cpp : 241 + 0x19]
 1  arx.exe!Cedric_AnimateDrawEntity(EERIE_3DOBJ *,ANIM_USE *,Angle<float> *,Vector3<float> *,Entity *,bool,bool) [animationrender.cpp : 1957 + 0x20]
 2  arx.exe!EERIEDrawAnimQuat(EERIE_3DOBJ *,ANIM_USE *,Angle<float> *,Vector3<float> *,unsigned long,Entity *,bool,bool) [animation.cpp : 618 + 0x28]
 3  arx.exe!RenderInter(float,float) [interactive.cpp : 3263 + 0x25]
 4  arx.exe!ARX_SCENE_Render(long) [scene.cpp : 3150 + 0x5]
 5  arx.exe!ArxGame::Render() [arxgame.cpp : 1690 + 0x5]
 6  arx.exe!ArxGame::Run() [arxgame.cpp : 599 + 0x12]
 7  arx.exe!WinMain [startup.cpp : 174 + 0x16]
 8  arx.exe!__tmainCRTStartup [crtexe.c : 547 + 0x1c]
 9  kernel32.dll + 0x17077


Registers:
  EAX:00000000  EBX:0012F97C  ECX:0A6B6FC8  EDX:0A6B6FC8  ESI:0B0663CC  EDI:0B066008
  CS:EIP:001B:7C817077
  SS:ESP:0023:0012FFC8  EBP:0012FFF0
  DS:0023  ES:0023  FS:003B  GS:0000
  Flags:00210246


Steps to reproduce this issue
just headed arx thru 2 lvl, nothing special

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 18, 18:27
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-3272-2616483597
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 18, 18:27
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-3272-2616483597
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 18, 18:27
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-3272-2616483597
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 18, 18:27
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-3272-2616483597
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Mar 18, 18:37
This is a known issue.

Unrelated from the crash: You are using the D3D9 renderer - please let us know if there are any problems with the OpenGL renderer.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.
#10
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 24, 18:42
just walkin thru lvl 4
#11
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 24, 18:42
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-3404-466980234
#12
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 24, 18:42
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-3404-466980234
#13
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 24, 18:42
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-3404-466980234
#14
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 24, 18:42
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-3404-466980234
#15
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 27, 13:35
hit load autosave key
#16
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 27, 13:35
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-4008-80868479
#17
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 27, 13:35
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-4008-80868479
#18
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 27, 13:35
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-4008-80868479
#19
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 27, 13:35
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-4008-80868479
#21
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 02, 15:07
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-3224-988376484
#20
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 02, 15:07
just after alia's reunion cutscene at lvl 4 i try to enter rebel camp. each time arx falls
#22
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 02, 15:07
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-3224-988376484
#23
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 02, 15:07
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-3224-988376484
#24
icon_reply.pngReply
Comment posted by
 CrashBot
Apr 02, 15:07
A file was uploaded. crash.xmlicon_open_new.png This comment was attached:

arxcrash-3224-988376484