Arx Libertatis Bug Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Crash report #1533  -  [A4D56796] arx.exe!Trail::Render() [Trail.cpp:117]
Posted Mar 22, 2021 - updated Jun 22, 2021   Shortlink: http://arx.vg/1533
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue is a duplicate of issue #1468 - "Shooting with the bow implementation crashes the game"
icon_info.png This issue has been closed with status "Not a bug" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Crash report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     CrashBot
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Not determined
  • Resolution
    DUPLICATE
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • OS
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png amd64
  • Fixed in
    icon_customdatatype.png Not determined
Issue description
Assertion Failed at Trail.cpp:117: m_positions.size() >= size_t(std::ceil(n)) 2

Unhandled exception

Exception code: BREAKPOINT

 Instruction address: 0x7ff75643100e
 Stack pointer: 0x6d100ff1d0


Callstack:
 arx.exe!0x7ff75643100e
 arx.exe!0x7ff7563f8e11
 arx.exe!0x7ff7563b8fca
 arx.exe!0x7ff7563b9956
 arx.exe!0x7ff7563b60d2
 arx.exe!0x7ff7563c7cfe
 arx.exe!0x7ff7564bf01a
 arx.exe!FT_GlyphSlot_Own_Bitmap()
 KERNEL32.DLL!BaseThreadInitThunk()
 ntdll.dll!RtlUserThreadStart()
Symbols:
 0  arx.exe!Trail::Render() [Trail.cpp : 117 + 0x1a]
 1  arx.exe!SpeedSpell::Update() [SpellsLvl03.cpp : 129 + 0x0]
 2  arx.exe!ArxGame::renderLevel() [ArxGame.cpp : 1948 + 0x122]
 3  arx.exe!ArxGame::render() [ArxGame.cpp : 2082 + 0x0]
 4  arx.exe!ArxGame::doFrame() [ArxGame.cpp : 1304 + 0x0]
 5  arx.exe!utf8_main(int,char * * const) [Startup.cpp : 164 + 0xa5]
 6  arx.exe!WinMain [WindowsMainGUI.cpp : 48 + 0xe]
Steps to reproduce this issue
Was returning to Arx after breaking the meteorite. Entered from the passage that was previously blocked by debris, I found a guard that pointed me to the prison. I get down to the plaza with the teletransporting crystal, attack a new enemy guard with a Fireball sphere and game crashed

#1
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 22, 20:09
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-12376-4272339828
#3
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 22, 20:09
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-12376-4272339828
#4
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 22, 20:09
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-12376-4272339828
#5
icon_reply.pngReply
Comment posted by
 CrashBot
Mar 22, 20:09
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-12376-4272339828
#7
icon_reply.pngReply
Comment posted by
 Daniel Scharrer
Apr 05, 16:57
Please use the latest development snapshot - this has been fixed for a long time.

The issue was updated with the following change(s):
  • This issue's description has been changed
  • This issue's title has been changed
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to DUPLICATE.
#9
icon_reply.pngReply
Comment posted by
 CrashBot
May 14, 17:24
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-12920-2745655009
#10
icon_reply.pngReply
Comment posted by
 CrashBot
May 14, 17:24
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-12920-2745655009
#8
icon_reply.pngReply
Comment posted by
 CrashBot
May 14, 17:24
I tried to shoot a fireballon an ylsid warrior
#11
icon_reply.pngReply
Comment posted by
 CrashBot
May 14, 17:24
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-12920-2745655009
#12
icon_reply.pngReply
Comment posted by
 CrashBot
May 14, 17:24
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-12920-2745655009
#13
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 21, 19:59
Game crashes whenever I start combat with Ylside
#14
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 21, 19:59
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-10040-2289344587
#17
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 21, 19:59
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-10040-2289344587
#15
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 21, 19:59
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-10040-2289344587
#16
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 21, 19:59
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-10040-2289344587
#19
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 22, 18:16
A file was uploaded. arx.logicon_open_new.png This comment was attached:

arxcrash-13084-2433878249
#18
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 22, 18:16
Game crashes when Ylside cast a spell. When I use negate magic, the game doesn't crash.
#20
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 22, 18:17
A file was uploaded. cfg.iniicon_open_new.png This comment was attached:

arxcrash-13084-2433878249
#21
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 22, 18:17
A file was uploaded. crash.dmpicon_open_new.png This comment was attached:

arxcrash-13084-2433878249
#22
icon_reply.pngReply
Comment posted by
 CrashBot
Jun 22, 18:17
A file was uploaded. crash.txticon_open_new.png This comment was attached:

arxcrash-13084-2433878249